Results 1 to 3 of 3
  1. #1

    Incorrect launcher Version

    Now I can't even get past the launcher?
    I was logged in yesterday on the Test server (the main server was down) and today it says 'Incorrect launcher version'?

    Did I miss something? How do I find the correct one? Don't tell me I have to download the 365GB patch again please...

  2. #2

  3. #3

    Re:Incorrect launcher Version

    Phew thanks :P

Similar Threads

  1. What are these icons going to be?
    By Bossman in forum Prelude Talk - General Discussion
    Replies: 2
    Last Post: 06-10-2010, 01:23 PM
  2. Czech Republic
    By Radevic in forum Off Topic
    Replies: 4
    Last Post: 05-28-2010, 02:23 AM
  3. I hate to ask, but how do we start refund process?
    By terter2000 in forum Prelude Talk - General Discussion
    Replies: 7
    Last Post: 05-20-2010, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •