Results 1 to 4 of 4
  1. #1

    Error: Incorrect Launcher Version

    Hey, just posting that the latest update gave ^ error in the patcher.

  2. #2

    Re: Error: Incorrect Launcher Version

    same here

  3. #3

    Re: Error: Incorrect Launcher Version

    Your launcher is outdated. Probably means a new launcher to download. Xsyon will make an announcement of a new launcher.
    There is the high level design of a gameplay mechanic. Then there is what everyone does in spite of it.

  4. #4

    Re: Error: Incorrect Launcher Version

    Yes, I just updated the launcher and posted about it. The main server is up.

Similar Threads

  1. What are these icons going to be?
    By Bossman in forum Prelude Talk - General Discussion
    Replies: 2
    Last Post: 06-10-2010, 01:23 PM
  2. Czech Republic
    By Radevic in forum Off Topic
    Replies: 4
    Last Post: 05-28-2010, 02:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •