Results 1 to 7 of 7
  1. #1

    Error: incorrect launcher version

    Hey!
    What's that?

    Error: incorrect launcher version



    it worked very well there two days !

  2. #2

    Re:Error: incorrect launcher version

    Hello Kimani,

    A new installer is available. It's posted in the Citizens section and I will PM you the link.

  3. #3

    Re:Error: incorrect launcher version

    and what if i cant see the citizen section (even if i preordered an can play) ?

  4. #4

    Re:Error: incorrect launcher version

    bork wrote:
    and what if i cant see the citizen section (even if i preordered an can play) ?

    pm Virtus to fix that

    I will send you a link

  5. #5

    Re:Error: incorrect launcher version

    same problem: no see the section; i pm virtus, but no response.

  6. #6

    Re:Error: incorrect launcher version

    kimani wrote:
    same problem: no see the section; i pm virtus, but no response.
    will, since you are posting in it, I'm guessing you can see it

  7. #7

    Re:Error: incorrect launcher version

    oups :blush:

Similar Threads

  1. What are these icons going to be?
    By Bossman in forum Prelude Talk - General Discussion
    Replies: 2
    Last Post: 06-10-2010, 01:23 PM
  2. Czech Republic
    By Radevic in forum Off Topic
    Replies: 4
    Last Post: 05-28-2010, 02:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •