Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Multiple networking issues causing all the problem

    First let me reference all my posts pointing to the same core issue.
    http://www.xsyon.com/forum/showthrea...stay-connected
    http://www.xsyon.com/forum/showthrea...ading-Entities
    http://www.xsyon.com/forum/showthrea...Random-crashes..

    In all my posts I've come to the conclusion loading entities is slow due to low download speeds, it goes extra slow when the connection stops receiving all-together, and then picks back up (perhaps error recovery but it takes a lonnnng time)

    In game I see huge lag spikes before a disconnect, sometimes up to 2 minutes of no bandwidth moving at all, then I get a sudden spike of data like 34k/s for about 15 seconds where everything in the world catches up, text floods real fast etc etc. Then the game runs normal again at the 3 - 5k/s normal bandwidth. As soon as commands stop working, or typing doesn't register, I see my bandwidth meter drop to nothing, and sometimes this disconnects me to login screen.
    The fact that this is intermittent, and doesn't effect everyone at once, generally means a hardware issue, or configuration issue on one of your many WAN IPs.


    Now to strengthen my statements above, I ran an ICMP to my own ISPs gateway, with 0 packet loss, 100% packets sent and received which mean "I DID NOT LOSE INTERNET CONNECTION, to any server except yours"
    I also ran into the following error messages several times while trying to post this, from your forums.

    Service Temporarily Unavailable

    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    ---------------------------------------------------------------
    Server error
    The website encountered an error while retrieving http://www.xsyon.com/forum/showthrea...stay-connected. It may be down for maintenance or configured incorrectly.
    Here are some suggestions:
    Reload this web page later.
    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.


    I hope that's enough proof to at least start looking at networking/configuration issues, if anyone has some REAL input to back this up would be much appreciated =).

  2. #2
    I just bought this game today, I'm very excited to play.
    Servers aren't UP?

    singleplayer?

    I'm sure they're doing everything they can to fix whats going on, I just hope I dont hafta wait all night

  3. #3
    The game is cool just a few issues need to be worked out at the moment.
    Servers are up...
    Single Player doesn't exist...
    As with most/all? mmorpgs, the communication sucks and we have no idea what they are looking into, or what they are fixing =/. More communication is always good, even if it's bad news.

  4. #4
    There's enough abbreviations i don't know and words i don't know in this guys post that i believe he knows what he's talking about.

    Devs should probably listen to him.

  5. #5
    lol, they are common abbreviations for networking, I'm just looking for someone to at least look at it as a possibility. I've seen similar behavior with major ISPs I had to argue with before they looked at their own network. The poor guys ran new lines, fiber all kinds of stuff they spent 2 months and it was a misconfigured router lol...
    Basically my theory on this one is they have multiple IPs on their WAN.
    In lamens terms, an IP is a house and the WAN is street. They have a whole freakin apartment complex with lots of IPs, but it's still going to the WAN or the street .

    One of those many IPs they own is misdirected (in my theory) or routed wrong, so all those packets that should go somewhere, get dropped into nowhere, which creates a biggggg lag spike when your computer isnt' getting updates from their server anymore. Then error correction is like yo I'm not getting any data and I'm gonna disconnect soon, but their server does quality control and pushes the same data at a super fast speed (to catchup for the time you didn't get any data) down another IP that IS pushing to the proper route, and it stays on that route for a while so you go around lag free, and yer like ya this is schweet no more lag they fixed it!!! and then like 2 hours later you get that bad link again and lag all to hell.

    That's my idea in theory I'm probably wrong but it's worth looking at.

  6. #6
    What address are you tracing?

  7. #7
    I'm not tracing any address, as I'm not sure what IP pool they use, although it wouldn't be hard to find. I just noticed when I get the lag spikes, and disconnect issues others are talking about, I'm seeing my network activity drop to almost nothing on a bandwidth monitor I run, yet at the same time I see downspeed drop (meaning the Xsyon server isn't sending me any data), I can still ping other internet addresses just fine. I also ran a bandwidth test during the time I had issues, to verify it wasn't my end, and it wasn't.

    I'm not saying Xsyon HAS bandwidth issues, I'm saying the problem I'm seeing seems to be data from the Xsyon servers stops completely, which causes the lagspikes, and in some cases disconnects. If it doesn't disconnect, I get a sudden burst of data, which is catching up from the lack of data to resync the game, and then all is well again.

    I'm basically trying to provide enough information and hard evidence as possible to help them diagnose the issues so I can play =).

    Tonight things ran awesome after I started posting stuff, probably a coincidence though =O.

  8. #8
    173.208.85.178 is the one someone PM'd me.

  9. #9
    That traces to hypernia server hosting company.. They do have a site in chicargo by the looks so i guess its them they use.

    haha in the us their premium dedicated server costs $395 but click the uk and that goes upto $500 nice..

  10. #10
    when your logged in run netstat -a -f and you will see usually the very last connection is the xsyon server when nothing else is using the internet on my pc.
    I almost always trace to the Xsyon server in under 80ms.

    I dont believe its a bandwidth issue i think its something to do with there world server
    TokTok - Axe Welding Basket Weaver

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •