Page 1 of 3 123 LastLast
Results 1 to 10 of 29
  1. #1

    Feedback Request 01/25/2014 - Test Session

    The Test Server is open for public testing of the following improvements:

    Changes 01/28/2014
    Camera view changed to have a fixed vertical field of view (instead of a fixed horizontal field of view, allowing wide screen resolutions a wider view.

    New input system further revised to fix reported issues. This system is still in progress.

    Important changes
    One currency used at trade totems - dollars. Other currencies are replaced with dollar bills
    Optimized crossing zones and entering to prevent lag
    Optimized skill and experience gain functions
    Optimized tree loading
    Keyboard input completely redone using a better input API. Should resolve various input issues.
    Chat input is now frame rate independent.

    Minor improvements
    Level up and level down adjusted to gain or use dirt only if the difference in heights being leveled exceeds 0.1 meters.
    Adjusted crafting panel so that crafting button works only if all required materials are present.
    Crafting cancels if you close the crafting panel.
    Experience not gained while using experience to increase skills through the leveling up panel.
    Tree stump positioning adjusted to prevent underground stumps
    Vertical gauges (life, energy etc.) graphics adjusted.
    Fixed the display of the Bonecraft upkeep buff.
    Power on some animal based crafted components corrected.
    Master Forager Bone File can be unlearned.
    Female armor sets display duration and wear.
    Totems should display 0 days last active for online players.
    You can now take damage when falling with a cart attached.
    Mini map glitch when near the center of a zone (512 position) and zone borders fixed.
    Tribe member inviting another receives messages regarding tribe size when an invited member accepts.

    Bugs fixed
    Issue 1664 Cart Bug??
    Issue 1884 Level down at flat ground gives 1 dirt
    Issue 1883 Mini Map showing incorrect picture for the location.
    Issue 1875 Totem
    Issue 1855 Unable to unlearn Master Forager's Bone File
    Issue 1854 Female armor no durability or condition displayed.
    Issue 1765 Crafting. Stuck in infinite loop
    Issue 1420 Planting trees
    Issue 1715 Terrain-Leveling sometimes rounds down instead of up
    Issue 33 NumPad does not work on login screen
    Issue 1290 Unable to create direct sound
    Issue 157 Changing Audio Device
    Issue 1434 Leader unable to see tribe radius comment
    Issue 223 Unable to create direct sound" wont launch from patcher

    Please Test:
    Skill gain from actions (scavenging, foraging, fishing)
    Skill gain from crafting
    Skill gain from running / jumping / swimming / hiding (check display and report)
    Scheme gain from crafting
    Scheme gain from pattern / blueprint
    Xp gain from skills
    Use count on skills
    Combat and skill gains in combat
    All keyboard input!

    If you find any problems with any of the above, please post in this thread with details on how to reproduce the problem.

    Please do not post any Test Server bugs in the Bug Reports section. It is better to keep all current issues with the test session here so that they can be dealt with expediently.

    Last edited by Xsyon; 01-28-2014 at 03:02 PM.

  2. #2
    I'm unable to use the tab key to go from "account name" box, to the "account password" box.
    I'm unable to use shift tab to go from "account password" box to the "account name" box.

    I can use the mouse to click on either box put in the information. Once I do this, and hit "enter" key, it does not log me into the game. I have to use the mouse to click the log in button.

    "Victorious warriors win first and then go to war, while defeated warriors go to war first and then seek to win."

  3. #3
    german keyboard:

    using ^ causes a tab-space, pushing tab doesnt do anything
    doesnt work
    apostophe ` dont work
    all things needing right alt pushed down dont work
    del doesnt work
    caps lock doesnt work
    insert creates a zero

    pressing a key just a lil bit too long causes multiple numbers of that letter too fast.

    lol .... (right beside the L) makes the line disapear through the upper border of the input-bar
    Last edited by ZitengWang; 01-26-2014 at 03:38 AM.

  4. #4
    Same with the login screen.

    I get problems with more keyboard lag in-game.. If I sprint for 3 seconds (W & X) I will continue to sprint for 2 to 3 more seconds after releasing the keys. Doesn't happen with R-Mouse, L-Mouse, & X.

    While sprinting, jumping is delayed (hit space bar and wait for it to happen).

  5. #5
    Comments taken from the Bug Report section:


    Movement Glitch/Bug (Test Server)
    Character keeps moving after movement key deactivated

    Was getting a ping of about 360 on the test server and it appears that while objects are still "loading" into the zone my character just kept walking sometimes quite a good distance after i released the movement key, after everything was fully loaded it wasn't as bad but still noticeable

    also the ping seems kinda high usually sit around 260 on the main server


    doesnt happen while moving side-or backwards, it seems.

    ping seems stable. i dont trust the number left side up anyways a shown ping round 20 on test-server, even while reproducing the "glitch/bug"

  6. #6
    Comments taken from the Bug Report section:


    Chat lag on test server

    Having 10 sec chat lag on test server

    Hey ,
    When logging into the test server I could not press tab to move to the password box or press enter to enter the game after typing in my password. I had to manually click them ( on main server I can press tab and enter). When I got into the test server I moved around side to side and forward and jumped and I had about 10 secs delay before these actions were completed. I tried a tiny bit later and it still happened.

    Kind Regards,

  7. #7
    To ZitengWang:

    Please check your email. I would like some direct help to solve the keyboard issues.


  8. #8
    Glorp here...testing from under his rock. Tested using Gruu. system spec AMD Phenom 3.0/8gb mem./nvidia 500ti 1gb/500gb sata hd, 1/2 full/windowed mode/comcast 15mb sec service.

    1. second account page Tab and enter do not have to click on the password to enter it and then you have to press the enter button to log in.
    2. random not being able to stop a movement between 1 to 3 sec delay. this is even during normal run or sprint.
    3. only tried scav, skill gain and count ok
    4. crafting, skill and count ok
    5. scheme from craft and scheme/bp ok
    6. xp gain looked ok
    7. use count ok
    8. I could not test skill gain on combat due to : Tested revs at decayed Hamsterbane camp, approx 60-80 revs in the zone
    and if in or out of combat mode i could not manuver properly ie: backing up to wait for the rev action so i could then hit without bieng hit...i kept moving backwards and could not stop...delay of 3-5 sec...this is any direction. but, on a marmot close to the same camp i could move and stop properly.
    9.I use a wolf king game pad in addition to the reg keyboard and mouse. I only tested the keys i normally use with no problem but also tested the alt key for combat that others say does not work...i use mouse combat but when mouse combat off i could use the alt key and it did work for me.
    10.death port from animal...time to reload was about 50% faster.
    11. exiting game....this may be from numerous reasons but i did not get an exit message,checked opening bins on self ok...went to chek other actions to see if a crash but then was taken to second log in screen.

    Hope this helps. Glorp

  9. #9
    Glorp wrote:
    8. I could not test skill gain on combat
    tested it. had a rev unwilling to fight back first, then he turned on me. skillgain seems ok, so far. gained 0.1 in axes after a few hits.

    hunting skillgain works.
    also exp-gain looks ok. foraging/scav. exp-gain seem to work too.

    Please check your email.
    done and answered

  10. #10
    "Keyboard input completely redone using a better input API. Should resolve various input issues."

    Only basic letter/number and adjacent keys are being recognized. I have my movement keys mapped to arrow keys (I'm a lefty) and these don't work. Camera mode is mapped to Home and that doesn't work. Bind Keys will not accept these keys as input.

    "Better" API's should accept all keys.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts