Results 1 to 10 of 10
  1. #1

    05/02/2015 - Bug Report Feedback Request

    Hello everyone!

    I am looking for some assistance to reproduce or close out previously reported bugs and issues. I am currently unable to reproduce these and would appreciate additional information or instructions if these are still problems.

    If you can reproduce any of these and provide more details or if you can confirm that these are fixed (as far as you know), please post in this thread.

    Thanks!

    1) Animals disappearing under ground when killed.
    Original issue is here

    My questions are:

    - Is this happening on terraformed land, untouched terrain or both?

    - The animals are disappearing or falling under the ground level when you kill them, correct?

    - Is this happening on sloped terrain, or flat terrain as well?

    - Is this happening to a specific type or size of animals, or all animals?

    2) Starting TeamSpeak takes up to 20 seconds if Xsyon is running. This was reported by one player, but I can't reproduce this on any system. Are other players experiencing this?
    Original issue is here

    If you can reproduce this, my questions are:

    - Are you running any anti-virus programs?


    - Does this happen all the time, or while you are loading Xsyon or crossing zones?

    So far, only one player can reproduce this. I don't have this issue on any machine and neither do other players that I've talked to. If you have TeamSpeak, please check this.

    3) Grass resource that can't be picked up. If you find a location where this happens, please post the exact location so that I can check this.
    Original issue is here

    - Has anyone seen this happen recently?

    - Is there a current in game location where this happens?

    4) Unable to drop baskets on floors. This was reported, but I can't reproduce this. If you can reproduce this, please give me an exaction location on the Test Server to check.

    I think I can close out the following issues. If you feel that these are still a problem, or if you can reproduce these and provide more information, please post.

    1) Unable to create a quest receiving the message '
    Quest Goal Incorrect. Quest Aborted.'. If anyone can reproduce this but the quest goal seems to be correct, I need more information. I think it was a simple matter of the quest goal not matching a correct name for an in game item.
    Original issue is here

    Note: Most likely this was an issue of not typing a valid quest goal name.

    2) Terrain not reverting. Can you reproduce this or give me a location to check? This may have been a one time issue with data not loading correctly for one player. If nobody can report this happening recently, I will close out the issue.
    Original issue is here

    Note: I checked the reported location and ran a sped up terrain reversion test. Most of the terrain was blocked from reversion by a current totem. A few spots did revert over time as intended. The area seems to be working properly at the moment.

    If no other areas are reported, I will close this one out, but keep an eye out on reverting terrain.

    3) HP Bars on creatures don't appear when in Combat mode.
    Original issue is here

    - Has this happened recently? If so, when? (more or less)

    - Can you reproduce this on the current Test Server?

    If this can't be reproduced at all, I will close the issue and it can be opened again if it reappears. Gauges have been revised and optimized and any strange problems with them should be gone.
    Last edited by Xsyon; 05-06-2015 at 12:49 AM.

  2. #2
    Yes plants are still disappearing under ground on the zone line. cords are 936/255/29 and 896/255/1023. I planted 9 carrots, only 6 are visible. You can see the little window for the other 3 but can't click on them.

  3. #3
    3) Location does not matter, it happend to me in a spot where i usual gather grass and never had this issue. it was not possible to gather grass anywhere. a relog solved it.

    4) You can reproduce it with a scrapper hangar roof 4x4, it will always happen with this roof, after you dismantle it.

    5)
    Quote Originally Posted by Xsyon View Post
    If you can reproduce this, my questions are:
    - Do you gain swimming skill but the use count doesn't update?
    correct, it does not update while you swim, thats all. i can cross the lake from N to S without a stop, even sprint all the way down, and it wont add any use in my skill window. as soon as i hit land or i change the locks while swimming, i'll gain like 15 uses at once.

    6) while xsyon is running, doesnt matter what i'm doing in the game

    7) Zone 978 X676,5 Z 547,5 H500.0. Thats the coords of a Scrapper Smoke House, which holds a bin Labled "Weaponcraft" there you can see the items i was reporting. diffrent kinds of leather have more than 1 stack and i can not put them together.


    9) This has been solved on testserver before we had the big crash, i remember you used the testserver to fix the datas of the lifeserver again, if you lost the bugsmashing backup this way i'll log to check this again.

    EDIT: I just figured that containes crafted by player still have "no" defaul locks and can be opend by everyone, even on tribal land. not sure if that was already fixed but maybe you can take a look at it since you get rid of all the bugs atm.

  4. #4
    Quote Originally Posted by zymmie View Post
    Yes plants are still disappearing under ground on the zone line. cords are 936/255/29 and 896/255/1023. I planted 9 carrots, only 6 are visible. You can see the little window for the other 3 but can't click on them.
    I will check this exact location on the Test Server today. Thanks!

  5. #5
    Quote Originally Posted by Pwnuts View Post
    3) Location does not matter, it happend to me in a spot where i usual gather grass and never had this issue. it was not possible to gather grass anywhere. a relog solved it.
    Did this happen only one time? It sounds like you were timed out or partially timed out and disconnected from the server.

    Has anyone else experienced this recently?

    Quote Originally Posted by Pwnuts View Post
    4) You can reproduce it with a scrapper hangar roof 4x4, it will always happen with this roof, after you dismantle it.
    Are there any other parts that this happens to? I see the problem with the scrapper hangar roof 4x4 and will patch a fixed scheme to the Test Server today.

    Quote Originally Posted by Pwnuts View Post
    5) Do you gain swimming skill but the use count doesn't update?
    correct, it does not update while you swim, thats all. i can cross the lake from N to S without a stop, even sprint all the way down, and it wont add any use in my skill window. as soon as i hit land or i change the locks while swimming, i'll gain like 15 uses at once.
    Could you check this on the Test Server? I've tested this by swimming across the lake and both the skill and use count updated correctly while swimming.

    Quote Originally Posted by Pwnuts View Post
    7) Zone 978 X676,5 Z 547,5 H500.0. Thats the coords of a Scrapper Smoke House, which holds a bin Labled "Weaponcraft" there you can see the items i was reporting. diffrent kinds of leather have more than 1 stack and i can not put them together.
    Ok. I will check this.

    Quote Originally Posted by Pwnuts View Post
    9) This has been solved on testserver before we had the big crash, i remember you used the testserver to fix the datas of the lifeserver again, if you lost the bugsmashing backup this way i'll log to check this again.
    Ok. I won't be able to load old data just yet. When I can I will let you know.

    Quote Originally Posted by Pwnuts View Post
    EDIT: I just figured that containes crafted by player still have "no" defaul locks and can be opend by everyone, even on tribal land. not sure if that was already fixed but maybe you can take a look at it since you get rid of all the bugs atm.
    This should be correct on the Test Server today. Please check and confirm if you can.

    Thanks!

  6. #6
    3) i didnt get a disconnect, i was not able to gather grass for about 2h. only this one time i mentioned, yes.

    4) not what i'm aware off, only the one i said.

    nr5 + "edit" will be checked later, not able to log on testserver atm.

    always happy to help getting rid of the last few bugs

  7. #7
    Xsyon Citizen
    Join Date
    Jul 2013
    Location
    Right by the Mist
    Posts
    116
    12) The original report on that was because my old tribe area hadn't changed since I left, which iirc was roughly a couple of months before I made that post. There's a couple of totems there now, but the terraforming I did still looks the same on test and on peace as it did the day I left, I checked yesterday.

    Location is the same as the one posted in the original report, which is zone 981 at 272 / 404

  8. #8
    Several issues have been fixed and moved to the Test Server Session Feedback here

    This includes planting crops on zone boundaries, issues with swimming skill gain, item stacking, the Scrapper Hangar Roof and other issues.

    I've revised the current list in the first post above. Please check it and let me know if you have further feedback on these issues as described above.

    Thanks!

  9. #9
    Xsyon Citizen
    Join Date
    Jul 2013
    Location
    Right by the Mist
    Posts
    116
    3) Grass resources that can't be picked up :- Could this be from a freshly respawned patch of grass, the first Spring after you added this feature I got a blob right at my front gate, and while it showed grass in the resources window it wouldn't allow me to pick it, iirc it took several real days before I could.

    4) Unable to drop baskets on floors :- chances are they had a ghost blocking the bin from being dropped, to check place and build a floor on the ground, then place a truss on the ground so it covers the floor and leave it as a ghost, now standing on the floor try and drop a bin.

    2) Terrain not reverting :- Just visited my old place and for the first time in roughly six months something has changed, or should that be two things as grass has finally started to grow on it as well. So while your keeping an eye on the reversion code you might want to keep the other eye on the grass regeneration code, as I don't think either of them is working as intended in every zone.

  10. #10
    Quote Originally Posted by Bejaymac View Post
    3) Grass resources that can't be picked up :- Could this be from a freshly respawned patch of grass, the first Spring after you added this feature I got a blob right at my front gate, and while it showed grass in the resources window it wouldn't allow me to pick it, iirc it took several real days before I could.
    Yes, that's what it was, freshly reverted grass. I was able to reproduce and fix this today. I haven't updated the Test Server with my fix yet, but I've been testing it repeatedly today and it's clear this was the problem.

    Quote Originally Posted by Bejaymac View Post
    4) Unable to drop baskets on floors :- chances are they had a ghost blocking the bin from being dropped, to check place and build a floor on the ground, then place a truss on the ground so it covers the floor and leave it as a ghost, now standing on the floor try and drop a bin.
    I'll try this.

    Quote Originally Posted by Bejaymac View Post
    2) Terrain not reverting :- Just visited my old place and for the first time in roughly six months something has changed, or should that be two things as grass has finally started to grow on it as well. So while your keeping an eye on the reversion code you might want to keep the other eye on the grass regeneration code, as I don't think either of them is working as intended in every zone.
    I figured out the problem. Reversion is working fine, but takes a long time. It also starts at zone 0 every time the server restarts. Because of this, some zones may not be reverting as often as they should (or not at all). Reversion is actually a lot slower right now than it should be. I'm speeding it up for the next patch and that should take care of spots that were taking too long to revert.

    Thanks for the info. It helped me track these hard to pinpoint issues!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •