PDA

View Full Version : D3D Device Creation Failed



deathrament
01-31-2011, 02:58 PM
i copied the game from my home pc to my laptop and im getting this error when launching. Any idea?

Virtus
01-31-2011, 03:05 PM
please post this in the bug reporter, thank you.

Xsyon
01-31-2011, 09:26 PM
Yes, you need to install the game on the other machine. Copying the game can cause problems.

Fred
02-17-2011, 11:07 PM
I did a fresh install, and I am getting this error.

Baldur
02-19-2011, 02:58 PM
I'm also getting this error. How do I submit a bug report?

edit: Deleted options.sav and fixed my problem.

Jizel
04-06-2011, 11:56 AM
I'm also getting this error. How do I submit a bug report?

edit: Deleted options.sav and fixed my problem.

I have played on my laptop before today, but I tried to log in today on my laptop and received this error also as described in this thread. I deleted the "options.save" file. It did also solve this problem. Odd that this error just popped up. It was a clean install not a copy. So perhaps the maintenance this morning caused this issue???

Mitsarugii
05-06-2011, 01:29 PM
im getting this error now i have installed the new patch

deleting the options.sav file doesnt help as i dont have an options.sav file

undeadfishboy
05-06-2011, 01:44 PM
mitsarugii yes u do have a options.sav it in Games\Xsyon\Save

Virtus
05-06-2011, 03:09 PM
if that doesn't work download directx and install again

Mitsarugii
05-08-2011, 09:26 PM
mitsarugii yes u do have a options.sav it in Games\Xsyon\Save


nope, my save folder had login.sav in it and nothing else

problem fixed either way, for some reason the new patch forced me to re-update my gfx card to get the game working

Pollygod
09-06-2011, 09:42 AM
I had this problem once....I have win7 and XP on diff drives I had game on XP first and all was fine ,I then wanted to see if it was better on win7 so I logged into my win7 drive and re downloaded game, the mistake I made here was the game default installed to my primary drive (XP) and on loading I would get that error and the it wouldn't work on my XP drive either so still on XP I went to uninstall thats when I discovered my mistake cause I couldn't un install cause it was installed from win7 to my XP drive lol SOOOO I removed it from win7 and had ta re install to XP all was well. Not sure if that helped anyone and I dont blame win7 at all but since the game works fine on XP thats what I use for now. Ok I've confused myself enough hope no one got a headache

Gasoline
01-18-2012, 04:53 PM
I have the same error. I launched the game once succesfully and got inside, everything was working nicely until it crashed. Now, after I try to launch it again, I get the same error D3D Device Creation Failed: ....

I already tried to delete options.sav and it did not help me, in addition to that, I tried to re-install DirectX but it said I have the latest version installed already and it's not possible to uninstall it.

I have already sent a mail to support and waiting for reply. Does anyone have any ideas?

fatboy21007
01-18-2012, 05:31 PM
try to install dx 9 then u should be fine

Gasoline
01-18-2012, 06:33 PM
I already have DX9. Just did a re-install to the game and the problem continues. :S