Deers Mutants and Normals Run away when hit
issueid=2635 04-03-2019 08:44 AM
chojinuk
Deers Mutants and Normals Run away when hit

Hunting Deers of any kind right is now kind of messed up.

One hit and they just run forever, across whole zones up sheer cliffs
They do not attack at all but just run away.

I dont know if its down to my Ping or not but even when Im on their back I cant hit them.

I have to get in front of where I think they are going to be in the next few tenths of a second and try and hit them before i SEE them reach that spot

Is this how its supposed to be now ?
Issue Details
Issue Number 2635
Project Bugs Reports
Category Unknown
Status Confirmed
Priority Unknown
Affected Version Unknown
Fixed Version (none)
Users able to reproduce bug 3
Users unable to reproduce bug 0
Assigned Users (none)
Tags (none)




04-03-2019 09:16 AM
Xsyon Citizen
I also noticed this bug regarding smaller mutated mammals. Dogs and Cats seem to run away indefinitely until they are killed.

04-05-2019 01:24 AM
Visitor
I managed to kill a small mutant with a low-hunting-skill new char, cause it simply tried to run away without hitting back until it died.

Even a shadow deer simply stared on my char for the first two hits, then turned and ran away up a steep cliff. Several animals have this behaviour: just staring for 2-3 hits, then turning and walking or running away.

In general I have the impression that mutants (even big ones) stop following my char quicker than before.

04-06-2019 04:00 AM
Xsyon Citizen
Think that's probably part of the "fight or flight" mechanics that have been added for when we get ranged weapons, from what I understand if an animal can't reach you it's meant to turn and run away, so if the animal isn't already agro at you when you first hit it, then it's likely to just turn and run, so the settings probably need tweaked per animal type.

Haven't checked for a while but if the larger animals still walk across the riverbeds instead of swim, then the hitboxes are are still messed up, which might explain the problem of hitting them when they are running away.

04-08-2019 04:01 AM
Xsyon Citizen
well I dont use Rocks to fight, I am always on the same plane/elevation as the animal, it can always hit me if it chooses to.
I am never out of its reach

So it shouldnt run from me as it can attack me at any time.

04-08-2019 04:04 AM
Xsyon Citizen
Deers dont have hit box problems its only the big bears.
before this patch I could hit a deer as it ran away from me, now i cannot

04-08-2019 04:30 PM
This is all a bit strange. I haven't turned on any parts of the new AI with this patch. However, some of the old AI does depend on DirectX library functions that are being deprecated and that I replaced with newer functions.

Also, possibly I patched some changes to the creature data files although at quick glance it doesn't look like it.

I will further review the data I patched.

However, I'm going to focus on moving forward with the new AI and we can test creatures and any potential issues with the new AI on the Test Server. I'm very close to wrapping it up and it should resolve problems that we've had with creatures (hit box issues, no height on creature positions, small creatures too hard, etc.).

04-15-2019 12:07 PM
Xsyon Citizen
As a reference point, I recorded this footage before you add the Taming Patch
so you can see the current position of animals, you say nothing has changed but
the animals are behaving differently.

Video 1
A hornback marmot does not fight back once, it just runs, then gets stuck

https://www.youtube.com/watch?v=OQGX1PBN3VE



Video 2
A Hunchback coyote gets stuck in walk mode and does break out of it
A deer ran after 1 hit and just keeps running.
I cant hit them when I am right behind them, I have to get in front
Maybe because my ping is high


https://www.youtube.com/watch?v=OQGX1PBN3VE


Video 3
Another hunchback getting stuck in walk mode

https://www.youtube.com/watch?v=UGIJS3_lumY


Video 4
A Mule Deer starts off super fast then gets stuck in walk mode, plus another deer
gets stuck in walk mode

https://www.youtube.com/watch?v=0qkXUMDrUtM


Video 5
A Shadow Bear I cant outrun, hits me 9 times in a few seconds - Super Speed Critter ??

https://www.youtube.com/watch?v=wVn12NOPrdQ


Video 6
A Deer just runs for ages
Cant hit a Rev in the back even though Im right on him, because he is moving
Takes ages for the rev to actually hit back
When the deer hits, sometimes there is no animation of its attack.

https://www.youtube.com/watch?v=hUKQySqhM-Y

04-15-2019 12:11 PM
Xsyon Citizen
Forgot to add the canis in video 6 gets stuck in walk mode also

04-15-2019 12:20 PM
Xsyon Citizen
The Correct link for video 2 is ie the hunchback getting stuck in walk mode

https://www.youtube.com/watch?v=ylYNhboxM6M

04-16-2019 10:56 AM
Xsyon Citizen
Quote Originally Posted by Xsyon
However, I'm going to focus on moving forward with the new AI and we can test creatures and any potential issues with the new AI on the Test Server. I'm very close to wrapping it up and it should resolve problems that we've had with creatures (hit box issues, no height on creature positions, small creatures too hard, etc.).
Yes, please!


Quote Originally Posted by chojinuk
A Shadow Bear I canít outrun, hits me 9 times in a few seconds - Super Speed Critter ??
I've experienced many of the creature behaviors you've encountered Sark but the above one is not new. I mentioned it way back, but it was not confirmed by others and got buried. It was somewhat rare a year or so back but recently I was on PvP server where there are lots of roaming animals (--unlike PvE server where many tribes have huge zoos full of pinned animals) and just about every other animal/ mutant had this super-speed bug. When you encounter one of these you cannot out run them unless you are on a road or can lose them in rocks/ other structures. And they hit with multi-attacks. I'm guessing this is not intentional so hopefully will get investigated down the road.

But, letís get some new content above all else, even if its buggy to start.

04-16-2019 11:31 AM
Xsyon Citizen
Quote Originally Posted by wastelandstoic
Yes, please!




I've experienced many of the creature behaviors you've encountered Sark but the above one is not new. I mentioned it way back, but it was not confirmed by others and got buried. It was somewhat rare a year or so back but recently I was on PvP server where there are lots of roaming animals (--unlike PvE server where many tribes have huge zoos full of pinned animals) and just about every other animal/ mutant had this super-speed bug. When you encounter one of these you cannot out run them unless you are on a road or can lose them in rocks/ other structures. And they hit with multi-attacks. I'm guessing this is not intentional so hopefully will get investigated down the road.

But, letís get some new content above all else, even if its buggy to start.
yes I know its now new but its the first time i could be bothered to record it, its been happening to me for a long time

04-16-2019 11:44 AM
Thanks for all the info and videos.

I patched a small update last night to fix some potential problems with the implementation of the upgraded DirectX math functions. If this has any effect on the creature AI, please let me know. (I'll be surprised if it does though!)

Most of the creature problems listed above have been reported in the past, but were reported as more rare or inconsistent. A lot of these issues sound like things that could happen when creature commands pile up on the client side.

Perhaps this is happening more due to the amount of penned up creatures? Perhaps the libraries I had to upgrade affect the piling up commands? Are there too many creatures in some zones now because I need to run the creature migration? I honestly don't have any answers. These are just questions running through my head.

I've debugged the old AI for hours this past week and all the variables look correct. The data hasn't changed.

Are the reported problems with creatures happening on a 100% consistent basis? Or are they happening in intervals and just sometimes or just in some areas (for example, where there are a lot of creatures nearby)?

The new AI (not yet patched) processes creature commands in larger batches. It's also much more streamlined and predictable code on the server side. What we tested so far looked good. I'm going to continue with the new AI this week so that we can test it again as soon as possible.

Thanks!

04-16-2019 01:39 PM
Xsyon Citizen
Quote Originally Posted by Xsyon
Thanks for all the info and videos.

I patched a small update last night to fix some potential problems with the implementation of the upgraded DirectX math functions. If this has any effect on the creature AI, please let me know. (I'll be surprised if it does though!)

Most of the creature problems listed above have been reported in the past, but were reported as more rare or inconsistent. A lot of these issues sound like things that could happen when creature commands pile up on the client side.

Perhaps this is happening more due to the amount of penned up creatures? Perhaps the libraries I had to upgrade affect the piling up commands? Are there too many creatures in some zones now because I need to run the creature migration? I honestly don't have any answers. These are just questions running through my head.

I've debugged the old AI for hours this past week and all the variables look correct. The data hasn't changed.

Are the reported problems with creatures happening on a 100% consistent basis? Or are they happening in intervals and just sometimes or just in some areas (for example, where there are a lot of creatures nearby)?

The new AI (not yet patched) processes creature commands in larger batches. It's also much more streamlined and predictable code on the server side. What we tested so far looked good. I'm going to continue with the new AI this week so that we can test it again as soon as possible.

Thanks!

The first video, the marmot, was a penned creature, the others were not penned and all took place a good zone away from penned creatures (my tribe) with any penned creatures.

Now I;ve had a chance to review the footage myself, not something i get to do, re-watch fights...

It seems to me, my euro ping is a large factor.

for eg, as you said commands stacking up and then occuring all at once, coupled with my euro ping explains the shadow bear super speed critter.


But the deers running away and the stuck in walk mode is occuring a lot, and is a relatively new thing.

I tried the test server I get a ping of 16 there, I suspect that i wouldn't get a super speed critter on the test server
but the animals were still getting stuck in walk mode.

from looking at the videos, the getting stuck in walk mode seems to be the happening more then the others.

I get that you cant do anything about my ping, and that you cant fix any issues that are caused by that, i suspect my ping will explain a lot of the things i recorded.

so as i said they are just a reference point, i dont expect you to put taming on hold for it.

04-17-2019 03:31 AM
Xsyon Citizen
One thing to check is the processes around the animals being recorded and written into the client log file.

Several months back on the test server I had rather brutal LAG after passing close to a couple of zoos, I was trying to talk with Michael at the time and it was taking several minutes for anything to show in the chat window, I also couldn't interact with anything.

Once I was clear of the zoos the LAG was still there, so I found a safe place, Alt+TAb out of the game and opened the client log in notepad, that seemed to clear the "bottleneck", as it took about 30 seconds after that before I could play normally again.

After that I started watching what was happening when I crossed boundaries, get a LAG spike and I'd stop to let the game catch up, too many animals in a small area seem to be the main stumbling block, as does crossing several boundaries too quickly.