Results 1 to 4 of 4
  1. #1

    07/23/2018 - Feedback Request - Synchronization & Lag (Test Server)

    The current Test Server build is running heavily revised positioning code (especially for creature positions).

    The creature AI on the server runs at a higher frame per second rate. Creature positions are being sent from the server and interpolated on the client side at a greater rate now as well.

    To handle this additional traffic I've revised how these positions are aggregated and communicated from the server to the clients. Our tests so far have resulted in much better performance in areas with a lot of creatures.

    My questions regarding this are:

    - Are other player movements better synchronized for you than on the Main Servers?

    - Are creature and other player movements smoother and with less sliding than on the Main Servers?

    - Do you experience any unusual lag in actions (such as dragging items in your inventory)? If so, can you reproduce the conditions?

    Note: The Test Server is in Europe, so US players will have lower than usual ping (while EU players should have better than usual ping). Please keep this in mind.

    Note: There may still be some action lag while first logging in to areas with a lot of buildings and / or creatures that need to load.

  2. #2
    Xsyon Citizen
    Join Date
    Jul 2013
    Location
    Right by the Mist
    Posts
    128
    Been getting LAG spikes when crossing sector boundaries pretty much from the start of testing, recent changes have reduced it by quite a bit, but it is still there. Only seems to happen when there are animals/revs near the boundary, the more there are the worse the spike, but if you just stop for a few seconds it will clear pretty quickly.

    Quote Originally Posted by Xsyon View Post
    Note: There may still be some action lag while first logging in to areas with a lot of buildings and / or creatures that need to load.
    Not just on logging in, just getting into draw range of some tribes is generating bucket loads of LAG, a mix of too many objects and too many animals is the cause, so even those of you on high end machines are going to be wondering WTF is going on, you have been warned

  3. #3
    If you have locations that are especially problematic please post a few here and I'll use them as test locations. My recent changes to creature network packets should improve things but it's tough. No matter what I do, there's a lot of objects and creatures to load. The 'lag' is actually caused by commands not being processed fast enough on the client side.

    I'll keep doing what I can to optimize processing though.

    Thanks!

  4. #4
    Xsyon Citizen
    Join Date
    Jul 2013
    Location
    Right by the Mist
    Posts
    128
    So far I have two problem tribes, you will probably already know which ones, The Valorinak Republic and Cloud Nine.

    The VR has always been a frame rate killer for me, but the 900+ spikes (normal for me on test is 61ms) is making it a real issue going near the place, the spikes ease off after a couple of minutes if you sit and wait.

    Cloud Nine doesn't bother my frame rate very much, there the issue is the amount of animals, in the roughly 10 minutes it took for the LAG to ease that new creature counter was showing 276 in the area.

    My PC probably doesn't help any, it was a mid level gaming rig when I bought it, almost 10 years ago now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •