Results 1 to 4 of 4
  1. #1

    Can't Enter game

    Registered, downloaded, patched. But when I click 'Enter' the launcher just disappears and nothing happens. I tried going to the Bug reports sub forum but there's no 'post new topic' button and at the top where it says if your having problems follow a link to post crash reports, the link is dead. I sent a message via 'Contact us' at the bottom of some page, but thought maybe I can get a faster response from the community in case this is a known issue. By the way I DID use the search feature and got nothing.

    My system specs

    Speccy Basic report
    Operating System
    MS Windows 7 Ultimate 64-bit
    AMD Phenom II X6 1055T
    Thuban 45nm Technology
    4.0GB Dual-Channel DDR3 @ 669MHz (9-9-9-24)
    Gigabyte Technology Co., Ltd. GA-880GA-UD3H (Socket M2)
    HD2201 (1680x1050@59Hz)
    NVIDIA GeForce GT 240

  2. #2
    Are you running as an Administrator?
    --Guide Michael
    Guardian of the South and Element of the fire, Chief of the Archangels, Angel of Justice, Strength and Protection.

  3. #3
    Tried running as Admin and normal, without result.

  4. #4
    Do you have any text files in your log folder where the game is installed? If you do please send those to support which you can contact here:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts