Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    11/24/2015 - Feedback Request Optimization Patch

    Hello everyone!

    If you have any feedback on today's Optimization Patch, please post it here. Loading times should be greatly improved and zone crossing 'lag' should be minimized.

    Although this patch is purely optimizations, it includes big changes to how the game client stores data and processes messages. If you notice any strange new issues, please post them here.


  2. #2
    Guide Ariel came on today (The 24th) saying that they had to take this patch off, because it was causing other problems. It was asked that we go onto the test server to try out to see if the new patch is working. Transferring inventory, opening bins, most every action worked fine until I tried to build a mason base post. The materials and tools loaded fine, but when I clicked build, it locked up my computer. After rebooting, I went back into test server and tried to build again with the same result. So in one respect, the lag was gone, but then trying to build my machine locked up so that isn't good.


  3. #3
    When trying to build the error message comes up "Sector Already Locked on Access Begin! Sector:0"

  4. #4
    When I went to put pieces on a previously dismantled mason wall the materials that were there previously weren't there. When I went to add a few bricks the mortar showed up automatically (when it wasn't showing when I opened the window).

  5. #5
    I have Pioneer Tri Posts as walls in my compound. As a test I dismantled some, however I was unable to "Cancel Project". I would get the following;

    "You must remove all materials to cancel this project".

    There are no materials present when viewed via "Open Project".

    As a further test, I continued along the wall dismantling until I ran into a post that actually had materials. It had 1 Douglas Fir Long Wood Post. I removed it to my inventory and was able to "cancel project" for this particular one. Be aware the long wood post once removed and placed in inventory showed as "ghosted/greyed out. Continuing on, the 18th post canceled normally, there were no materials in it. 19 also. I must point out, these two where the only ones which game me the message "all materials lost" after I click on Dismantle.

    These results are based on 30 posts.

    Further testing on one of the posts which would not cancel, yet had no materials present, revealed if you add a a long wood post
    into the build window it will disappear.

    NOTE: I tried to make this as short as possible, but it became wordy. I then took a short video, (less than 1 minute) of what I was seeing, I can post it as a private link, if you feel it will help.
    Last edited by GIJoe597; 11-24-2015 at 11:30 AM.

  6. #6
    Tried to build a granite wall, loaded mats and hit build... it gave me error: Sector Already Locked On Access Begin! Sector: 0 and then froze the game. I re-logged and all mats were gone. Added bricks, mortar shows up as being there already.
    I built again, got the same message. However, this time it allowed the construction of the wall and then froze the game. I once again logged back in and tried to build a beam. I got the same error message, but I closed the building window before completion and it said invalid location but did not freeze the game. Then I went to open my cart and again, the game froze.

    When moving arch, constantly getting message: You can’t move this beyond tribal bounds
    When moving pieces of shadow ach between zones, still drops arch piece.

    I also noticed more lag in the test server than on the normal PVE.
    Cooking appears disabled as I am unable to cook anything.

  7. #7
    Xsyon Citizen
    Join Date
    Jul 2013
    Right by the Mist
    Confirmed with the error on building, you get a popup with Sector Already Locked On Access Begin! Sector: 0 in it, click the button and the 0 changes to a 1 and then a 2 and again to 3, then you can hear the sound of tools as the building process starts, however the client locks up just as the project finishes.

    Been lucky with the couple of attempts I've tried in that I was able to bring up task manager and kill the client in it, rather than needing to reboot.

    Should add it was railings I was testing with, 4 separate materials in them which might explain the four error messages I got.
    Last edited by Bejaymac; 11-24-2015 at 02:05 PM.

  8. #8
    Thanks for all the info! This build is a tough one to check as there are changes to around 200 functions.

    I've uploaded the latest build. This should fix the following issues:

    1) Building should work properly, without the 'Sector Already Locked' error and freeze.
    2) Materials in existing projects should appear correctly always.
    3) Cooking should work.

    All other functions should also work properly. If any further issues are found, please let me know.


  9. #9
    Had no problems with this build.

    Built a couple posts, moved them, dismantled and removed parts with no problem. Did a little cooking. Tried several crafts, a little combat, lots of running around, etc. and noticed no difference except for reduced time on lag spikes.

  10. #10
    I've updated the Main Servers again with this update. If there are any new issues, please continue to report them here.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts